Инструменты пользователя

Инструменты сайта


stepbystep:protect1c

Различия

Здесь показаны различия между двумя версиями данной страницы.

Ссылка на это сравнение

Следующая версия
Предыдущая версия
stepbystep:protect1c [2016/11/18 14:05]
mcvet создано
stepbystep:protect1c [2020/04/07 12:22] (текущий)
Строка 14: Строка 14:
   - Скачайте файл демонстрационной базы "​КошкинДом.dt"​ (ссылка в электронном письме).   - Скачайте файл демонстрационной базы "​КошкинДом.dt"​ (ссылка в электронном письме).
   - Создайте информационную базу из загрузите в нее копию из скаченнего файла.\\ Структура конфигурации имеет следующий вид. {{ :​stepbystep:​21-10-2016_11-23-09.png?​nolink |}} В справочнике "​Котики"​ содержится информацию о животных. При добавлении нового животного в справочник в качестве имени можно выбрать одну из популярных кличек. Клички хранятся в регистре сведений,​ а код для выборки записей из этого регистра расположен в общем модуле "​КотыСервер"​.   - Создайте информационную базу из загрузите в нее копию из скаченнего файла.\\ Структура конфигурации имеет следующий вид. {{ :​stepbystep:​21-10-2016_11-23-09.png?​nolink |}} В справочнике "​Котики"​ содержится информацию о животных. При добавлении нового животного в справочник в качестве имени можно выбрать одну из популярных кличек. Клички хранятся в регистре сведений,​ а код для выборки записей из этого регистра расположен в общем модуле "​КотыСервер"​.
-  - Откройте модуль формы элемента справочника "​Котики"​. Модуль содержит код для заполнения выпадающего списка "​Кличка"​ известными именами котов. Выборка элементов для списка выполняется в общем модуле "​КотыСервер"​.<​code>&​НаСервереБезКонтекста+  - Откройте модуль формы элемента справочника "​Котики"​. Модуль содержит код для заполнения выпадающего списка "​Кличка"​ известными именами котов. Выборка элементов для списка выполняется в общем модуле "​КотыСервер"​.<​sxh>&​НаСервереБезКонтекста
 Функция ПолучитьСписокКличек(Пол) Функция ПолучитьСписокКличек(Пол)
   
Строка 37: Строка 37:
  Элементы.Кличка.СписокВыбора.ЗагрузитьЗначения(КличкиКотов);​  Элементы.Кличка.СписокВыбора.ЗагрузитьЗначения(КличкиКотов);​
   
-КонецПроцедуры</​code+КонецПроцедуры</​sxh
-  - Перейдите к модулю "​КотыСервер"​. Выборка кличек выполняется простым запросом с одним параметром. Код этого модуля будет в дальнейшем скрыт, а функция "​ПолучитьСписокКличек"​ будет требовать наличие лицензии на продукт.<​code>​Функция ПолучитьКличкиКотов(Пол) Экспорт+  - Перейдите к модулю "​КотыСервер"​. Выборка кличек выполняется простым запросом с одним параметром. Код этого модуля будет в дальнейшем скрыт, а функция "​ПолучитьСписокКличек"​ будет требовать наличие лицензии на продукт.<​sxh>​Функция ПолучитьКличкиКотов(Пол) Экспорт
   
  Запрос = Новый Запрос;​  Запрос = Новый Запрос;​
Строка 56: Строка 56:
  Возврат МассивКличек;​  Возврат МассивКличек;​
      
-КонецФункции</​code>+КонецФункции</​sxh>
  
 ===== Регистрация продукта в личном кабинете ===== ===== Регистрация продукта в личном кабинете =====
Строка 81: Строка 81:
   - Перенесите объекты (общие модули,​ макеты,​ формы) подсистемы "​МИКО_СистемаЛицензирования"​ в защищаемую конфигурацию.   - Перенесите объекты (общие модули,​ макеты,​ формы) подсистемы "​МИКО_СистемаЛицензирования"​ в защищаемую конфигурацию.
   - Откройте общий модуль "​МИКО_ЛицензированиеПереопределяемый"​.   - Откройте общий модуль "​МИКО_ЛицензированиеПереопределяемый"​.
-  - Заполнение тело процедуры "​ЛицензируемыеПродукты",​ указав наименование продукта и идентификаторы,​ полученные на предыдущих шагах (обведены синим цветом)<​code>​Процедура ЛицензируемыеПродукты(Продукты) Экспорт+  - Заполнение тело процедуры "​ЛицензируемыеПродукты",​ указав наименование продукта и идентификаторы,​ полученные на предыдущих шагах (обведены синим цветом)<​sxh>​Процедура ЛицензируемыеПродукты(Продукты) Экспорт
   
  ОписаниеПродукта = Новый Структура;​  ОписаниеПродукта = Новый Структура;​
Строка 92: Строка 92:
  Продукты.Добавить(ОписаниеПродукта);​  Продукты.Добавить(ОписаниеПродукта);​
   
-КонецПроцедуры</​code+КонецПроцедуры</​sxh
-  - В этом же модуле нужно указать местоположение макетов внешних компонент. В данном примере компоненты подключаются к демо-серверу лицензирования. Для подключения к собственным серверам требуются персонализированные под разработчика компоненты,​ получить их можно по запросу. <code>+  - В этом же модуле нужно указать местоположение макетов внешних компонент. В данном примере компоненты подключаются к демо-серверу лицензирования. Для подключения к собственным серверам требуются персонализированные под разработчика компоненты,​ получить их можно по запросу. <sxh>
 Процедура ПриИнициализацииЗакрытогоМодуля(ПрефиксКлюч,​ МестоположениеКомпонента) Экспорт Процедура ПриИнициализацииЗакрытогоМодуля(ПрефиксКлюч,​ МестоположениеКомпонента) Экспорт
   
Строка 108: Строка 108:
  КонецЕсли;​  КонецЕсли;​
   
-КонецПроцедуры</​code+КонецПроцедуры</​sxh
-  - Для работы закрытого модуля потребуется лицензионный ключ. Система будет периодически запрашивать ключ, а также может выдать новый при регистрации продукта.<​code>​Процедура ПриЧтенииЛицензионногоКлюча(ИдентификаторКонфигурации,​ ЛицензионныйКлюч) Экспорт+  - Для работы закрытого модуля потребуется лицензионный ключ. Система будет периодически запрашивать ключ, а также может выдать новый при регистрации продукта.<​sxh>​Процедура ПриЧтенииЛицензионногоКлюча(ИдентификаторКонфигурации,​ ЛицензионныйКлюч) Экспорт
   
  Если ИдентификаторКонфигурации= "​9cf50201-976d-11e6-810f-0050568123f9"​ Тогда  Если ИдентификаторКонфигурации= "​9cf50201-976d-11e6-810f-0050568123f9"​ Тогда
Строка 123: Строка 123:
  КонецЕсли;​  КонецЕсли;​
   
-КонецПроцедуры</​code>+КонецПроцедуры</​sxh>
   - Обновите конфигурацию базы данных.   - Обновите конфигурацию базы данных.
   - Настройте поставку конфигурации так, чтобы исходный текст модуля "​КотыСервер"​ был исключен из конфигурации.   - Настройте поставку конфигурации так, чтобы исходный текст модуля "​КотыСервер"​ был исключен из конфигурации.
Строка 144: Строка 144:
  
 Чтобы пользователь мог получить лицензионный ключ потребуется добавить форму регистрации. Чтобы пользователь мог получить лицензионный ключ потребуется добавить форму регистрации.
-  - Откройте модуль управляемого приложения и добавьте в него код следующего содержания:​ <code>+  - Откройте модуль управляемого приложения и добавьте в него код следующего содержания:​ <sxh>
 Процедура ПриНачалеРаботыСистемы() Процедура ПриНачалеРаботыСистемы()
   
Строка 182: Строка 182:
  МИКО_Лицензирование.ЗавершитьРаботу(НаименованиеКонфигурации);​  МИКО_Лицензирование.ЗавершитьРаботу(НаименованиеКонфигурации);​
   
-КонецПроцедуры</​code>+КонецПроцедуры</​sxh>
   - Обновите и запустите информационную базу. При первом запуске появится окно регистрации продукта. {{ :​stepbystep:​18-11-2016_11-33-48.png?​nolink |}}   - Обновите и запустите информационную базу. При первом запуске появится окно регистрации продукта. {{ :​stepbystep:​18-11-2016_11-33-48.png?​nolink |}}
   - Нажмите кнопку "​Перейти к регистрации клиента..."​ и заполните анкету нового клиента. {{ :​stepbystep:​18-11-2016_11-34-07.png?​nolink |}}   - Нажмите кнопку "​Перейти к регистрации клиента..."​ и заполните анкету нового клиента. {{ :​stepbystep:​18-11-2016_11-34-07.png?​nolink |}}
stepbystep/protect1c.1479467101.txt.gz · Последние изменения: 2020/04/07 12:11 (внешнее изменение)